Jump to content
Auriel22

.gob pitch and .gob roll being strange.

Recommended Posts

Posted (edited)

     Hi. Last Friday in Discord, I went to support in Epsilon Discord with a problem involving how objects were behaving with rotation and movement commands. I included a GIF showing what happened with an explanation of the process, which will be included here.

It is noteworthy that in the GIF, I was using macros in order to recreate the bug that was occurring for the sake of having enough time to be able to catch it in the GIF. However, the bug occurred regardless of whether or not I was using macros. I spawned the tile where I needed it to be, and did .gob pitch 90 and then .gob roll 90 to get the tile angled, and then began moving it to where it had to be in small increments like I normally would. I would move the tile twice before its rotation was reset, ruining its alignment. I was told to try to do the process the other way around, moving the tile into position before adjusting its rotation. This worked until yesterday, where I ran into the same issue again using curbs. I did .gob pitch 90 to stand the curb upright on its end, and then .gob turn 90, which ruined its rotation by turning it at an angle that was not 90 degrees. I didn't use macros when this occurred.

One final thing to note is that I have the ObjectMover addon, but I wasn't using it to rotate either the tile or the curb when both bugs occurred.

https://gyazo.com/1057924228531137fe0a2a3840fc5b35

EDIT: Ran into more interesting breaks. Adding a new GIF link.
https://gyazo.com/b083933fb4a5bb1baf0bc00a32d172ed

Edited by Auriel22

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×