Jump to content
Sign in to follow this  
The Frey

[Item Forge] Ranged Subtype Has No Range

Recommended Posts

Posted (edited)

Type of Bug: Weapon Range

Description: ItemForge-crafted items with the Ranged subtype do not have range, and instead only fire in melee range.

Evidence (Chat message/Screenshot):

In the first screenshot, you may notice that my [S.A.F.E. Multi-Purpose Disinfector] (14000254) is an ItemForged weapon (given the custom name and the ID). Please note that the Fake Shot spell in the first (1) slot of my action bar is marked red with the weapon equipped while having an NPC targetted.

As you can also see from the combat log, I've tried Fake Shot twice and it's failed because I'm out of range.

image.thumb.png.706577e1bd39c5a91c8125f55770e929.png

In this second screenshot, I've relocated closer to the Training Boss NPC and used Fake Shot at melee range. As you can see, the animation and effect fire off (pun intended), and Fake Shot is no longer marked in red.

image.thumb.png.2b12b0bbe502c050bd728ca08db256da.png

In this third screenshot, you can see that I've switched to the Blizzard item that I took my own forged item's parameters from, the Rifle of the Platinum Guard. As you can see, I returned to my original position and it works just fine across the board. I've even tried using Fake Shot repeatedly and it fires off every time.

image.thumb.png.cab5e5eb46177c1b00979e92a55c867b.png

Steps to reproduce: Create an ItemForged weapon whether through copying or manually-inputting the parameters and it should still produce a Ranged subtype weapon that only fires off in melee range.

Expected result: The expected result is that the custom Ranged-subtype weapon would fire off even--and especially--at range, as well as firing in melee range.

Observed result: The observed result is that said custom Ranged-subtype weapons only fire off at melee range. Outside of that, the (Out of Range) error displays itself.

Reproduction rate: Doing some quick maths and the evidence so far, I'd say it's close to a 100% reproduction rate.

Additional information: I am Frey and I love custom items, macros, and spell/visual effects. Thank you

Edited by The Frey

Share this post


Link to post
Share on other sites

God this crap again. 5 years later and it still rears its ugly head.

Applied a fix.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×