Jump to content

NPC Riding Flying mount Not Hovering Help pls

Recommended Posts





I've been trying to get this npc (mounted via mount command) to be able to sit stationary in the air hover flying on his mount (mount in the hover emote) and absolutely nothing seems to stick

I've tried the hover command, which only affects the rider and not the dragon. The fly command, which works sometimes temporarily but is reset on a relog/restart/.ref

No emotes or anims seem to affect the mount, again only affecting the rider. (tried the swim command for npcs too, no luck)

Two force fly or set fly spells were given to me but neither of those worked either. 

I honestly have no clue how to get him to just do his hover animation with the dragon and persist through .ref's and restart (I saw one night elf npc in another phase doing this fine, but for the life of me I can't get it to work with this guy)

Would love some help. Thank you. ❤️

Share this post

Link to post
Share on other sites

I don't know how much of a permanent solution this is, I just figured this out on my own, I had the same problem as you, I am also relatively new. What I did to get them to hover in place (a.k.a. flap their wings in the air) was making them flyable with ".npc set flyable", using ".npc move" to move them to where I wanted them in the air and then using the command ".npc set autohover always" (I don't know if the always matters instead of dynamic, etc., but I did that for my personal use).

After putting the auto hover on, I removed their flyability by repeating the command ".npc set flyable", and then did it again to give them flying back, so once more: ".npc set flyable", should say in the chat they can fly, and the mount's wings should start moving.

It worked for me, I hope it works for you too! ❤️


Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.