Jump to content
Sign in to follow this  

Launcher stuck at launching

Recommended Posts


I recently downloaded the Epsilon Launcher and placed it in a folder outside of Downloads (C:/Games/Epsilon). It had a button with a text updating, after a while turning into launch. As I pressed the Launch button, the text turned into launching and nothing happened after 15 minutes of waiting. Just in case, I deleted the folder, re-placed the launcher .exe and tried again, but the Launcher appears to be stuck at launching.

The folder currently looks like this:

  • _retail_
    • Interface
    • Patches
    • Tools
    • WTF
    • discord_game_sdk.dll
    • EpsilonAddon.dll
    • FreeImage.dll
    • shaders.hlsl
    • visualize_depth.hlsl
    • Wow.exe
  • cache
  • config
  • Epsilon
  • patches
  • Updater
  • VC_redist.x64

It says version 8.3.0 and whilst I can even move through the menu as it is launching, the patches section is empty whilst the news section appears to have latest news, I tried to look in the fixed solutions archive, but my look didn't seem to produce any others who had the same problem and a solution.

Thank you for reading my message!

Share this post

Link to post
Share on other sites

Your best place for help is going to be on our discord, in the #tech-support channel, so we can help in real time. This issue can sometimes be that the game is launching and just still downloading content it needs to fully open, and is going slow. You can check this in Task Manager and make sure there’s a WoW.exe background process (may be a sub-process of Epsilon.exe).



Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.